foros.eduroam.es » Problemas » Dispositivos móviles

CA para Symbian Universidad de Santiago

(12 mensajes)
  1. iago.rodriguez.rai_usc
    Miembro

    Hola a todos,

    Tengo un nokia X6 y he seguido el manual de la UAM para la configuración de la red eduroam, pero el apartado para descarga de los certificados de autentificación no puedo realizarlo allí, ya que no formo parte de esa universidad ni sé si funcionarían.

    En la Universidad de Santiago, no he visto colgado nada para Symbian, y cuando contacté con el servicio de atención al cliente para consultar sobre estos certificados no he obtenido respuesta. Mi terminal no se conecta tan sólo con la configuración del manual, con lo cual me temo que sean imprescindible el archivo CA.

    ¿Alguien sabe si los certificados de otra universidad servirían para esta eduroam y, en caso de ser así, podría facilitármelo de alguna forma?

    Muchas gracias de antemano por todo.

    Publicado hace 5 años #
  2. macias
    Administrador

    Hola,

    La USC parece usar Cybertrust. En formato PEM está por aquí:

    http://www.usc.es/gl/servizos/atic/rede/senfios/descargas/wifiusc.pem

    Pero creo que los nokia no lo aceptaban en ese formato, sólo en DER (con extensión .crt, mírate la guía que tenemos colgada en el foro). De todos modos, esta CA creo que debería estar instalada de serie en el teléfono, ¿no te aparece?

    Aparte, el nombre de servidor a validar es radius.usc.es

    Al menos eso es lo que se deduce de la configuración de Linux, que está colgada por aquí:

    http://www.usc.es/gl/servizos/atic/rede/senfios/wifiusc/linux.html

    Saludos!

    Publicado hace 5 años #
  3. Carlos
    Moderador

    Hola,

    En esta web se puden convertir los certificados de PEM to .crt

    https://www.sslshopper.com/ssl-converter.html

    Un saludo.

    Publicado hace 5 años #
  4. macias
    Administrador

    Gracias Carlos! Me la apunto para añadir la referencia a la guía de Nokia.

    Saludos

    Publicado hace 5 años #
  5. Miguel Macías
    Moderador

    Hola,

    Instalar un certificado raíz es una operación que debería evitarse y, sin embargo, hay una cierta sensación de que es necesario para que las cosas funcionen.

    En este caso concreto, Symbian ya incorpora de fábrica el certificado de 'GTE CyberTrust Global Root', como indicaba Macías, así que no es necesario instalar nada y ése no sería el problema de conexión.

    Por otra parte, si instalar un certificado raíz es 'peligroso', confiar su conversión a una herramienta online me parece 'temerario'.

    Lo ideal sería que cada institución proporcionase los certificados raíz (si es que fuese necesario) en ambos formatos, pero el usuario final siempre puede convertir directamente entre formatos:

    · en windows:
    certutil -decode certificado.pem certificado.der

    · en Linux:
    openssl x509 -inform PEM -outform DER -in certificado.pem -out certificado.der

    Saludos

    Publicado hace 5 años #
  6. iago.rodriguez.rai_usc
    Miembro

    Hola a todos,

    Antes de nada, muchísimas gracias por todas vuestras respuestas y ayuda.
    Perdonad mi ignorancia, pero tanto con el ordenador como con el móvil he tratado de descargar el certificado para luego probar a hacer la conversión a DER, pero no consigo hacer otra cosa que abrir el archivo como texto..

    Por otro lado, es cierto que si se trata de GTE CyberTrust Global Root, creo que es el que había seleccionado cuando traté de configurar la wifi de entre las posibilidades que trae instaladas el móvil, pero no funciona (al menos eduroam). El manual que había seguido es este: http://foros.eduroam.es/topic/guia-generica-configuracion-de-eap-ttlspap-en-symbian

    Se trata del que me decíais que está en el foro, no? Finalmente, comentar que ese servidor (radius.usc.es) quizás pueda ser el problema, ya que mi cuenta es rai.usc.es (la de cualquier alumno y que luego heredas en etapa de doctorado) y quizás tenga que abrir otro tipo de cuenta, aunque me extrañaría, ya que en el portatil no había tenido que hacerlo cuando instalé todo el jaleo de SecureW32, etc.

    Muchas gracias por todo una vez más y un saludo.

    Publicado hace 5 años #
  7. macias
    Administrador

    Hola,

    niños-no-hagáis-esto-en-casa... como dice Miguel Macías, la instalación de una CA que debería ir ya instalada puede ser algo delicado... en cualquier caso, prueba dos cosas:

    1.- Mira si tienes instalada la CA con nombre: "GTE CyberTrust Global Root". Si lo está, perfecto, ese es el que tienes que seleccionar.
    2.- Si no lo estuviera, adjunto el formato que /debería/ dejar instalarse en los nokia (formato DER pero con extensión .crt). La idea es que lo descargues, navegues localmente hasta el lugar de la descarga, y lo abras.

    Si se deja instalar y te aparece ya en el listado, seguimos viendo el resto de configuración.

    Saludos!

    Adjuntos

    1. wifiusc.crt (0.6 KB, 3 downloads) 5 años old
    Publicado hace 5 años #
  8. iago.rodriguez.rai_usc
    Miembro

    Hola macías,

    Muchas gracias otra vez por tu ayuda y por todas las molestias que te estás tomando con mi problema.
    Te cuento que sí que tengo en el móvil la CA GTE CyberTrust Global Root, aunque por si acaso había algún problema con ella traté de instalar el archivo que me habías pasado. No me permitió hacerlo porque dijo que el certificado ya existía...

    La verdad es que sigo sin lograr conectarlo, tanto a eduroam como a wifiusc, (da fallo de autentificación EAP-TTLS) y ambos los configuré según los pasos que aparecen en ese manual de este foro que había enlazado más arriba.. No sé lo que puede estar pasando, porque además es bastante peculiar algo que sucede, que es que desde que añadí esos dos puntos de acceso conigurados, no aparece en el listado de wifi's detectadas la intensidad de señal con la que se reciben..

    Anteriormente había probado también la configuración que dicen en la UAM, que es ligeramente diferente a la de este manual (hay que añadir un par de protocolos más en el cifrado), y antes de hacer ello también había probado la configuración que incluían en otro manual que había visto en un foro symbian para modelos más antiguos.. Y la verdad es que todos me dan el mismo problema..

    Lo único que se me ocurre es que pueda haber algún problema con mi cuenta, por ser rai.usc.es en vez del radius.usc.es que tan bien habías comentado arriba, pero es un poco raro que sea así...

    En fin, muchísimas gracias otra vez por todo y un saludo

    Publicado hace 5 años #
  9. macias
    Administrador

    Hola,

    pues no se me ocurre qué más pueda ser. Comentas:

    Lo único que se me ocurre es que pueda haber algún problema con mi cuenta, por ser rai.usc.es en vez del radius.usc.es que tan bien habías comentado arriba, pero es un poco raro que sea así...

    Y: el nombre de usuario es distinto al dominio que tienes que validar del certificado; éste último tiene que ser radius.usc.es, según se deduce de la configuración que está publicada para Linux.

    Y la combinación, como decía más arriba: EAP-TTLS con PAP.
    Lo único adicional que se me ocurre que pueda ser es que tengas una versión de firmware demasiado antigua, o algún tipo de problema local, pero si es esto tendrías que depurarlo con la ayuda de tu propia institución.

    ¿podrías contactar con el CAU de USC en cau@usc.es e indicarles tu problema? Por favor, remiteles a este hilo del foro para que lo actualicen si encontráis la solución.

    Siento no poderte ser de más ayuda...

    Saludos!

    Publicado hace 5 años #
  10. iago.rodriguez.rai_usc
    Miembro

    Hola Macías,

    Muchas gracias de nuevo por tu ayuda, les explicaré el problema ahora que he probado más cosas que cuando había contactado con ellos anteriormente, a ver si así aparece el problema y además como muy bien dices podemos dejar aquí eso resuelto para todos.

    Por cierto, decías que habías deducido que radius.usc.es es el dominio donde se ha de validar el certificado, pero eso he de hacerlo de algún modo cuando configuro el teléfono? Lo digo porque, si es así, no lo he hecho porque quizás me pasó desapercibido cómo hacerlo al seguir el manual.. Donde introduje de algún modo el dominio siempre era mi nombre de usuario, espero que no sea ese el problema..

    Un saludo y muchas gracias otra vez por todo

    Publicado hace 5 años #
  11. macias
    Administrador

    Hola,

    nada, perdona. He estado repasando la guía y parece que Symbian no deja configurar este parámetro (eso está mal, pero en fin...). Así que olvídalo. Trata de seguir la guía genérica en cualquier caso:

    http://foros.eduroam.es/topic/guia-generica-configuracion-de-eap-ttlspap-en-symbian#post-334

    En el nombre de usuario debes introducir por lo general el mismo dominio de tu cuenta de correo de USC, aunque ahora mismo dudo si debería ser en tu caso @rai.usc.es o @usc.es. En el ejemplo de Linux es @usc.es, pero no vaya a ser que una cuenta en rai.usc.es no sea válida para eduroam. Mejor consultarlo en cualquier caso...

    Saludos.

    Publicado hace 5 años #
  12. iago.rodriguez.rai_usc
    Miembro

    Hola,

    Como siempre muchas gracias por tu ayuda y tus consejos, Macías, y perdona que no haya respondido antes pero tenía la intención de hacerlo con el problema ya resuelto, o al menos respondido en algún sentido por parte del CAU de la USC, cosa que no ha sucedido todavía... a pesar de las dos consultas que ya he realizado desde hace cerca un mes..

    En fin, si finalmente puedo solucionar esto seréis los primeros en saberlo.

    Muchas gracias por todo y un saludo

    Publicado hace 5 años #

Feed RSS para este tema

Responder

Debes Identificarte para publicar.