foros.eduroam.es » Localizaciones

Desconexión inmediatamente después de autenticación exitosa

(17 mensajes)
  1. igonzalez836_uned
    Miembro

    Hola, soy un estudiante de la UNED y tengo problemas para acceder a internet en la Biblioteca del Patín, en el campus universitario de Ferrol, en A Coruña.
    Mi sistema operativo es Debian Wheezy. Deduzco que no es un problema en mi archivo de configuración que utilizo con el comando wpa_supplicant porque puedo conectarme a otras redes eduroam de Galicia y acceder a internet sin problemas. Os facilito un framento de la salida del comando wpa_supplicant:

    # wpa_supplicant -c ~/wpa_supplicant_eduroam.conf -i wlan0 -D wext &
    ioctl[SIOCSIWENCODEEXT]: Invalid argument
    ioctl[SIOCSIWSCAN]: Device or resource busy
    wlan0: Failed to initiate AP scan
    ioctl[SIOCSIWSCAN]: Device or resource busy
    wlan0: Failed to initiate AP scan
    ioctl[SIOCSIWSCAN]: Device or resource busy
    wlan0: Failed to initiate AP scan
    wlan0: Trying to associate with 00:0b:0e:45:e3:00 (SSID='eduroam' freq=2417 MHz)
    wlan0: Associated with 00:0b:0e:45:e3:00
    wlan0: CTRL-EVENT-EAP-STARTED EAP authentication started
    wlan0: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=21
    wlan0: CTRL-EVENT-EAP-METHOD EAP vendor 0 method 21 (TTLS) selected
    wlan0: CTRL-EVENT-EAP-PEER-CERT depth=3 subject='/C=SE/O=AddTrust AB/OU=AddTrust External TTP Network/CN=AddTrust External CA Root'
    wlan0: CTRL-EVENT-EAP-PEER-CERT depth=2 subject='/C=US/ST=UT/L=Salt Lake City/O=The USERTRUST Network/OU=http://www.usertrust.com/CN=UTN-USERFirst-Hardware'
    wlan0: CTRL-EVENT-EAP-PEER-CERT depth=1 subject='/C=NL/O=TERENA/CN=TERENA SSL CA'
    wlan0: CTRL-EVENT-EAP-PEER-CERT depth=0 subject='/OU=Domain Control Validated/CN=eduroam.uned.es'
    wlan0: CTRL-EVENT-EAP-SUCCESS EAP authentication completed successfully
    wlan0: CTRL-EVENT-DISCONNECTED bssid=00:0b:0e:45:e3:00 reason=0
    ioctl[SIOCSIWENCODEEXT]: Invalid argument
    ioctl[SIOCSIWENCODEEXT]: Invalid argument
    wlan0: Trying to associate with 00:0b:0e:45:c4:00 (SSID='eduroam' freq=2442 MHz)
    wlan0: Associated with 00:0b:0e:45:c4:00
    wlan0: CTRL-EVENT-EAP-STARTED EAP authentication started
    wlan0: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=21
    wlan0: CTRL-EVENT-EAP-METHOD EAP vendor 0 method 21 (TTLS) selected
    wlan0: CTRL-EVENT-EAP-PEER-CERT depth=3 subject='/C=SE/O=AddTrust AB/OU=AddTrust External TTP Network/CN=AddTrust External CA Root'
    wlan0: CTRL-EVENT-EAP-PEER-CERT depth=2 subject='/C=US/ST=UT/L=Salt Lake City/O=The USERTRUST Network/OU=http://www.usertrust.com/CN=UTN-USERFirst-Hardware'
    wlan0: CTRL-EVENT-EAP-PEER-CERT depth=1 subject='/C=NL/O=TERENA/CN=TERENA SSL CA'
    wlan0: CTRL-EVENT-EAP-PEER-CERT depth=0 subject='/OU=Domain Control Validated/CN=eduroam.uned.es'
    wlan0: CTRL-EVENT-EAP-SUCCESS EAP authentication completed successfully
    wlan0: CTRL-EVENT-DISCONNECTED bssid=00:0b:0e:45:c4:00 reason=0
    [...]

    Como podéis ver, inmediatamente después de la autenticación ocurre una desconexión de la que no soy responsable. Os proporciono la salida por consola del mismo comando en una red eduroam en la que no tengo problemas, en la sala de lectura de la UNED de Ferrol:

    # wpa_supplicant -c ~/wpa_supplicant_eduroam.conf -i wlan0 -D wext
    ioctl[SIOCSIWENCODEEXT]: Invalid argument
    ioctl[SIOCSIWENCODEEXT]: Invalid argument
    wlan0: Trying to associate with 00:24:97:2d:2b:81 (SSID='eduroam' freq=2462 MHz)
    wlan0: Associated with 00:24:97:2d:2b:81
    wlan0: CTRL-EVENT-EAP-STARTED EAP authentication started
    wlan0: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=21
    wlan0: CTRL-EVENT-EAP-METHOD EAP vendor 0 method 21 (TTLS) selected
    wlan0: CTRL-EVENT-EAP-PEER-CERT depth=3 subject='/C=SE/O=AddTrust AB/OU=AddTrust External TTP Network/CN=AddTrust External CA Root'
    wlan0: CTRL-EVENT-EAP-PEER-CERT depth=2 subject='/C=US/ST=UT/L=Salt Lake City/O=The USERTRUST Network/OU=http://www.usertrust.com/CN=UTN-USERFirst-Hardware'
    wlan0: CTRL-EVENT-EAP-PEER-CERT depth=1 subject='/C=NL/O=TERENA/CN=TERENA SSL CA'
    wlan0: CTRL-EVENT-EAP-PEER-CERT depth=0 subject='/OU=Domain Control Validated/CN=eduroam.uned.es'
    wlan0: CTRL-EVENT-EAP-SUCCESS EAP authentication completed successfully
    wlan0: WPA: Key negotiation completed with 00:24:97:2d:2b:81 [PTK=CCMP GTK=TKIP]
    wlan0: CTRL-EVENT-CONNECTED - Connection to 00:24:97:2d:2b:81 completed (auth) [id=0 id_str=]

    Y siempre utilizando el mismo archivo de configuración y el mismo certificado .pem TERENA.

    Si necesitáis algo más no dudéis en preguntar. Muchas gracias por la ayuda, espero vuestra respuesta.

    Publicado hace 4 años #
  2. igonzalez836_uned
    Miembro

    Hola, tenía pensado resubir el tema con este mensaje pero ya está arriba de todo.
    En cualquier caso, ¿hay alguna novedad en la resolución del problema de la red Eduroam en la Biblioteca Pública del Patín del campus universitario de Ferrol?
    Ahora mismo está de adorno.

    Gracias.

    Publicado hace 3 años #
  3. macias
    Administrador

    Hola,

    ¿se trataba de una instalación de UNED o de otra universidad? Si es un problema local (como parece), hay que verlo con el proveedor de servicio en esa localización.

    Por favor, confirma si se trata de un edificio de UNED o de UDC.

    Saludos.

    EDITADO: Perdona, no había leído lo de la sala de lectura de UNED. Se lo comento a los técnicos de UNED.

    Publicado hace 3 años #
  4. igonzalez836_uned
    Miembro

    Hola, la red eduroam con problemas está en la Biblioteca Pública del Patín, en el campus universitario de Ferrol. En la sala de lectura de la UNED de Ferrol la red funciona sin problema. Hice referencia a la sala de lectura de la UNEd de Ferrol solo para cotejar las salidas y tratar de confirmar que no es un problema de configuración por mi parte. Siento que haya creado confusión.

    Creo que se trata de un edificio de la UDC, pero no podría asegurarlo. No creo que sea un edificio de la UNED.

    Gracias.

    Editado: Que sea un edificio de la UDC lo infiero del texto de este link:
    http://www.udc.es/sobreUDC/localizacion/ferrol/esteiro/bibl_patin/index.html?language=es

    Publicado hace 3 años #
  5. csi00003_uned
    Miembro

    Hola,

    confirmo que no es una instalación de la UNED.
    En los log de nuestro lado (UNED), la última vez que tenemos registro de conexión en itinerancia del identificador igonzalez836 es el 10 de enero a las 8:38. Posteriormente hay conexiones los días 13 y 14 desde 'eduroam' en instalaciones/dependencias de la UNED.

    Tienen que verlo nuestros compañeros de la UDC.

    Un saludo

    Publicado hace 3 años #
  6. macias
    Administrador

    hola,

    por tanto la dirección sería Biblioteca Pública del Patín, en el campus universitario de Ferrol de UDC. ¿correcto?

    Saludos!

    Publicado hace 3 años #
  7. igonzalez836_uned
    Miembro

    Hola.

    Gracias csi00003_uned.

    El nombre que utilizan en la página de la Universidad de Coruña es Biblioteca "Casa do Patín", y está en el campus universitario de Ferrol de la UDC.

    Un saludo.

    Publicado hace 3 años #
  8. miguel.gonzalez_udc
    Miembro

    Hola,

    con un usuario de pruebas que nos pasó la UNED y la siguiente configuración del cliente wpa_supplicant nos funcionó correctamente:

    network={
    ssid="eduroam"
    scan_ssid=1
    key_mgmt=WPA-EAP
    pairwise=CCMP TKIP
    group=CCMP TKIP
    eap=TTLS
    identity="usuario@uned.es"
    anonymous_identity="anonymous@uned.es"
    password="AquiElPassword"
    ca_cert="/path_to/TERENASSL_PATH.pem"
    phase2="auth=PAP"
    }

    La cadena de certificación se puede obtener en:
    http://www.rediris.es/scs/cacrt/TERENASSL_PATH.pem

    ¿Puedes comprobar que la configuración es similar?

    Un saludo.

    Publicado hace 3 años #
  9. igonzalez836_uned
    Miembro

    Hola,

    El archivo de configuración que utilizo es, omitiendo información personal:

    eapol_version=2
    network={
    ssid="eduroam"
    key_mgmt=WPA-EAP
    proto=WPA2
    eap=TTLS
    ca_cert="/ruta_a_certificado/TERENASSL_PATH.pem"
    altsubject_match="DNS:eduroam.uned.es"
    anonymous_identity="anonymous@uned.es"
    identity="mi_identificador_de_usuario@alumno.uned.es"
    password="mi_contraseña"
    phase2="auth=PAP"
    priority=2
    }

    Saludos.

    Editado: Eliminada información personal.

    Publicado hace 3 años #
  10. macias
    Administrador

    Hola,

    sólo se me ocurre lo del valor del altsubject_match. Comentalo o borralo y pon en su lugar:

    subject_match="eduroam.uned.es"

    Saludos.

    Publicado hace 3 años #
  11. jgonzalez1380_uned
    Miembro

    Hola, me llamo Jorge y mi problema es el mismo que el de igonzalez836_uned en el mismo sitio(patín UDC).

    Estáis proponiendo cambiar el archivo de configuración que la UNED indica en su página de conexiones eduroam(algunos parámetros, "subject_match") pero, no tiene sentido porque funcionan en las demás universidades como por ejemplo en la biblioteca Concepción Arenal de la Universidad de Santiago.

    Entonces mi razonamiento es: si el único sitio donde no funciona es en UDC, no sería lógico pensar que el problema es de UDC?.

    Sino, los de la UNED que pongan en la página web los archivos de configuración para cada universidad.

    Saludos,
    Jorge.

    Publicado hace 3 años #
  12. igonzalez836_uned
    Miembro

    Hola,

    Gracias jgonzalez1380, opino lo mismo.

    Si la solución pasa por cambiar el archivo de configuración hay muchas posibilidades (todas) de que haya más usuarios de la UNED que tengan problemas en la UDC.

    Saludos.

    Publicado hace 3 años #
  13. macias
    Administrador

    Holas,

    mi sugerencia era en base al asunto del certificado que estoy viendo en el servidor de UNED:

    TLS: tls_verify_cb - preverify_ok=1 err=0 (ok) ca_cert_verify=1 depth=0 buf='/OU=Domain Control Validated/CN=eduroam.uned.es'
    CTRL-EVENT-EAP-PEER-CERT depth=0 subject='/OU=Domain Control Validated/CN=eduroam.uned.es'

    Parece que el nombre aparece en el Subject, y no en el AltSubject.

    Pero sí, tiene toda la lógica del mundo lo que decís...

    Intento moverlo por UDC entonces...

    Saludos.

    Publicado hace 3 años #
  14. manuel.posse_udc
    Miembro

    Hola,

    Tenéis el Network Manager deshabilitado?

    Si lo tenéis habilitado os puede dar problemas a la hora de ejecutar el wpa_suplicant a mano.

    Saludos,

    Manuel.

    Publicado hace 3 años #
  15. igonzalez836_uned
    Miembro

    Hola manuel.posse_udc, gracias por la información. Yo utilizo WICD, tengo más control con él.

    Saludos.

    Publicado hace 3 años #
  16. igonzalez836_uned
    Miembro

    Hola,

    esta mañana he vuelto a la biblioteca de Patín y eduroam sigue sin funcionar, ni con la configuración que utilizo en las redes eduroam de la UNED de Ferrol y Pontevedra, ni con la configuración que ha facilitado miguel.gonzalez_udc, ni con la modificación del 'alt_subject' que ha sugerido macias.
    Sigue habiendo el mismo comportamiento que comento en el primer post.

    Saludos.

    Publicado hace 3 años #
  17. igonzalez836_uned
    Miembro

    Hola, ¿hay novedades con este tema?
    Las redes eduroam de la biblioteca del Patín siguen sin funcionar. Sigue habiendo el mismo comportamiento que indico en el primer post.

    Saludos.

    Publicado hace 3 años #

Feed RSS para este tema

Responder

Debes Identificarte para publicar.